Cisco vs HP vs Dell CLI - Interface Configuration

After working with all three switch manufacturers in a short period of time, I figured I would do a quick post on how each chooses how to implement VLANs at the interface level.

Scenario 1: Switchport needs to be part of a single native VLAN (VLAN 10)

Cisco IOS:

interface GigabitEthernet1/1
switchport mode access
switchport access vlan 10

HP Procurve:

vlan 10
untag 1

Dell Powerconnect:

interface ethernet 1/g1
switchport mode access
switchport access vlan 10

Scenario 2: Switchport needs to be part of a single native VLAN (VLAN 10) and multiple tagged VLANS (VLAN 20,30)

Cisco IOS:

interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30

Note: Without the switchport trunk allowed vlan 10,20,30, the port will trunk all VLAN's, so it will work. I have gotten into the habit of specifying which VLAN's are allowed so that each port operates as designed.

HP Procurve:

vlan 10
untag 1
vlan 20
tagged 1
vlan 30
tagged 1

Dell Powerconnect:

interface ethernet 1/g1
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10
switchport general allowed vlan add 20,30 tagged
switchport general allowed vlan remove 1

Obviously the Dell configuration looks a bit convoluted here, but they do require you to manually remove VLAN 1 even though you have specified a different PVID.